Update: this issue has been fixed by the packagers. See the bug for more info.
I saw the notice about the KDE 4.6.0 RC1 packages being released for Kubuntu 10.10 today and decided to look at upgrading (or at least grab all the packages with
aptitude dist-upgrade -d) and got a surprise that it wanted to remove 250 packages due to dependency problems. The issues were:
The following packages have unmet dependencies: libqapt-runtime: Depends: libpolkit-qt-1-1 which is a virtual package. polkit-kde-1: Depends: libpolkit-qt-1-1 which is a virtual package. kdelibs5-plugins: Depends: libpolkit-qt-1-1 which is a virtual package. libgpgme++2: Depends: libgpg-error0 (>= 1.10) but 1.6-1ubuntu2 is installed.
Turns out that
libpolkit-qt-1-1 and the newer version of
libgpg-error0 are in the alpha for the next version of Kubuntu (Natty Narwhal) but not in Maverick (10.10), hence the chaos. The bug is reported as LP bug #694053 and thanks to Murz for spotting that you can just grab and
dpkg -i the missing packages – see the bug report for details and links!